SiComponents Home Page SiComponents Forums
Here you will be able to get help and share your experience
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Fixing Format Strings

 
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite
View previous topic :: View next topic  
Author Message
plumothy



Joined: 25 Oct 2010
Posts: 16

PostPosted: Fri Feb 14, 2020 2:46 pm    Post subject: Fixing Format Strings Reply with quote

When siLang fixes format strings it works OK if they are simple ones like '% s' (gets fixed to '%s').

But it does not work for ones which contain an index specifier. So this one '% 0: s' does not get fixed.

Is this by design or is it a bug?
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2187

PostPosted: Sat Feb 15, 2020 4:30 am    Post subject: Reply with quote

This is how it is realized but we will try to improve this.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by p h p B B  © 2001, 2005 p h p B B  Group