String ID column lost

General questions and announcements will be posted here.
Post Reply
Hydrokephalos
Posts: 9
Joined: Fri Mar 11, 2011 4:36 pm

String ID column lost

Post by Hydrokephalos »

Hi you all,

I have a major problem. I have a modul which contains only one siLang component. There I have only entries in the String section. I access them by there number, which is of course is written in the String ID column. That is very felxible and works fine.

Doubleclicking the component always opens the Translation Editor showing the first Language most left. Moving the horizontal scrollbar brought the String ID column into the window.

But from one day to the other the behaviour changed. As before I see in the left the first language and the scrollbar near the left end. But moving it leftmost, the String ID column does not appear, nothing happens. That is not good, because I now can not add more lines. Okay, I can, but can't give them an number, which makes it sensless. Where is my String ID column? How can I get it back?

Kind regards

Hydro

isiticov
Site Admin
Posts: 2207
Joined: Thu Nov 21, 2002 3:17 pm

Post by isiticov »

Hello,

It looks like you have somehow resized the String ID column to 0. Please try the following:
1. Open Registry Editor
2. Find the key: [HKEY_CURRENT_USER\Software\SiComponents\TsiLang\EditorForm]
3. Set the value for ColumnWidth1 entry to some value more than 0.

Hydrokephalos
Posts: 9
Joined: Fri Mar 11, 2011 4:36 pm

Post by Hydrokephalos »

Hello Igor,

thank you for your fast reply. I will try it on monday and will write a post about the result.

Kind regards

Hydro

Hydrokephalos
Posts: 9
Joined: Fri Mar 11, 2011 4:36 pm

problem fixed

Post by Hydrokephalos »

Hello,

I've tried to do it the way you described. I found the key, but it was set to 416, not 0. But that brought to me the idea to try once more, to resize the column in the usual way, by drawing the line with the mouse to the right.

It was a little bit tricky, but did work in the end.

Thank you.....

Пока

Hydro

Post Reply