TsiLang Files editor.

This forum designated to discuss the TsiLang Components Suite.
Post Reply
Thomas Bornhaupt
Posts: 10
Joined: Fri Nov 29, 2002 2:40 pm

TsiLang Files editor.

Post by Thomas Bornhaupt »

Hi Igor,

on my Win98Se German machine i see the icon for all *.sil files are changed to the icon from FilesEditor. A dobbleClick on this files open then the Files Editor, but the file is not opened. You have to do it by your own.

Regards
Thomas

dorin
Posts: 20
Joined: Thu Nov 21, 2002 3:29 pm
Location: House of Technics
Contact:

Post by dorin »

The *.sil (or *.sib) files may not be associated or not correctly associated with TsiLang Files Editor.
To verify that, go to the Options dialog, and make sure the Use Editor for SIL files is checked. Click OK.

Dorin.

Thomas Bornhaupt
Posts: 10
Joined: Fri Nov 29, 2002 2:40 pm

Post by Thomas Bornhaupt »

Hi,

you are right "Use Editor for SIL" was not checkt. After changing it works.

But if the *.sil file has icon of the SIl-Editor then everyone knows a dobbleclick opens the editor. That's windows. But why is there i "use Editor for Sil" checkbox?

regards
Thomas

dorin
Posts: 20
Joined: Thu Nov 21, 2002 3:29 pm
Location: House of Technics
Contact:

Post by dorin »

Actually this option should change both file association and file icon. So this option is included to enable the user to manage TsiLang files association by himself.

The problem is that Windows sometimes use icons from a cache and therefore it might use icons that are longer associated to a file type. This is probably your case.

Thomas Bornhaupt
Posts: 10
Joined: Fri Nov 29, 2002 2:40 pm

Post by Thomas Bornhaupt »

Hi,

thats is a to simple answer.

Yes icons are comming from a cash, so the icon looks correct, but a doppleclick does not found a associatet programm. I know, there was no file association before the installation. And thats not the problem, because the association was correct. The sil-editor starts by dobbleclick. But the sil-Editor does not load the file. So there could be two bugs. The installation does the assocation not correct (witout parameter), or the sil-editor does not look for the parameter. This bug you can only find out if clean the installation and all registry information

HKEY_CLASSES_ROOT\.sil
HKEY_CLASSES_ROOT\TsiLangFile\Shell\Open

And have you tested to uncheck "use Editor for Sil". The registry information is still there. (a new bug?)

reagards

Post Reply