Version 2.1.1 has major bugs

This forum designated to discuss the Resource Builder
Nicolas
Posts: 21
Joined: Thu Sep 04, 2003 3:31 pm

Version 2.1.1 has major bugs

Post by Nicolas »

Hello,

I sent a message last sunday to support, I got no answer so far. So I post a message here.

Version 2.1 words fine. Version 2.1.1 has two major defects :

1/When compiling the name of generated RES file is xxxres instead of xxx.res

2/When I open any of my previous drc files, I may get "Unexpected end of file". Or I may get this error when compiling. If I hit the compile button one again no error is reported.

Due to these defects command line scripts do not work anymore.

Please put back version 2.1 on line until these problems are fixed.

Thank you
:(

isiticov
Site Admin
Posts: 2217
Joined: Thu Nov 21, 2002 3:17 pm

Post by isiticov »

We've sent you the reply but it looks like you didn't received it. Please find below it cited:

Hello,
Thanks for info. The version on site updated in order to fix mentioned bugs and also if you prefer you can use old version from
http://www.sicomponents.com/soft/old/rbsetup.zip

Please let me know if it works now for you.

Nicolas
Posts: 21
Joined: Thu Sep 04, 2003 3:31 pm

Given link point to 2.1.1

Post by Nicolas »

Hello,

Thank you for your prompt answer.

I downloaded the link you provided. It points to 2.1.1 instead of 2.1. Could you please fix it?

Thank you

Nicolas

isiticov
Site Admin
Posts: 2217
Joined: Thu Nov 21, 2002 3:17 pm

Post by isiticov »

Sorry, I don't understand. At the http://www.sicomponents.com/soft/old/rbsetup.zip is placed version 2.1.0.3 and at our download page http://www.sicomponents.com/download.html is link to version 2.1.1.1 which contains the reported bugs fixed. Could you please specify which one doesn't work for you?

Nicolas
Posts: 21
Joined: Thu Sep 04, 2003 3:31 pm

Post by Nicolas »

Hello,

When I install what is provided at : http://www.sicomponents.com/soft/old/rbsetup.zip I still get version 2.1.1.0 (that is the bugged version)

However I did not know there is a new version 2.1.1.1 that fixes reported bugs. So I will upgrade to this new version shortly.

In any case I will let you know the results

Thank you for your assistance

isiticov
Site Admin
Posts: 2217
Joined: Thu Nov 21, 2002 3:17 pm

Post by isiticov »

Nicolas wrote: When I install what is provided at : http://www.sicomponents.com/soft/old/rbsetup.zip I still get version 2.1.1.0 (that is the bugged version)
Actually, it just looks like you've used the version from your cache. Could you please verify the file size in bytes (it should be 4468160 Bytes)?

Nicolas
Posts: 21
Joined: Thu Sep 04, 2003 3:31 pm

Post by Nicolas »

Size of downloaded zip file is 4 468 160 bytes. Before I install this version I uninstall the previous one (otherwise the installer will not let you install)

In the meantime I upgraded to 2.1.1.1 Situation is worse. I get unexpected end of file at random places in the file.

isiticov
Site Admin
Posts: 2217
Joined: Thu Nov 21, 2002 3:17 pm

Post by isiticov »

This is really strange. Are you sure that after uninstall there is nothing left in Resource Builder's folder? I mean please check that all DLLs were deleted as well.

isiticov
Site Admin
Posts: 2217
Joined: Thu Nov 21, 2002 3:17 pm

Post by isiticov »

If this is not the case please make the following:
1. Go to command line prompt
2. Go to Resource Builder's folder
3. Execute command DIR >1.txt
4. Please show us or send by email the content of 1.txt file.

Thanks.

Nicolas
Posts: 21
Joined: Thu Sep 04, 2003 3:31 pm

Post by Nicolas »

The folder is almost empty. Here is what sits in RB folder :

06/04/2004 17:48 <REP> .
06/04/2004 17:48 <REP> ..
06/04/2004 17:48 0 1.txt
22/01/2004 16:37 <REP> help
10/09/2003 17:09 1&#255;001&#255;472 temp.000
10/09/2003 17:09 180&#255;224 temp.001
22/01/2004 16:37 198&#255;144 temp.002
22/01/2004 16:37 1&#255;007&#255;104 temp.003
04/04/2004 15:13 1&#255;045&#255;504 temp.004
04/04/2004 15:13 123&#255;392 temp.005
04/04/2004 15:13 158&#255;208 temp.006
06/04/2004 16:44 1&#255;023&#255;488 temp.007
06/04/2004 16:44 18&#255;432 updater.exe
10 fichier(s) 4&#255;755&#255;968 octets
3 R‚p(s) 25&#255;920&#255;147&#255;456 octets libres

In the help folder the is only one help file : ResBuilder.chm

isiticov
Site Admin
Posts: 2217
Joined: Thu Nov 21, 2002 3:17 pm

Post by isiticov »

I assume that picture was after un-installing Resource Builder 2? Please delete all files before installing new version (just in case). Please install new version and provide us with the DIR content again.

Nicolas
Posts: 21
Joined: Thu Sep 04, 2003 3:31 pm

Post by Nicolas »

isiticov wrote:I assume that picture was after un-installing Resource Builder 2? .
Yes picture is after un-installing
isiticov wrote: Install new version .
Which one do you want me to install : 2.1.1.1 or the one that is related to the /old link (that is supposed to be the previous version?)

Nicolas
Posts: 21
Joined: Thu Sep 04, 2003 3:31 pm

Post by Nicolas »

So I deleted SiComponents folder that holds the Resource builder folder.
I installed RB and I have now 2.1.0.3 running! (which is what I was looking for)
It sounds very strange to me.

I do confirm as well that the two initially reported bugs are not there anymore (the most annoying one beeing "end on file detected").

I'm willing to help you to tackle the issue. I you need a file let me know.

isiticov
Site Admin
Posts: 2217
Joined: Thu Nov 21, 2002 3:17 pm

Post by isiticov »

Glad to see that it finally worked for you. The situation was really strange.
I also hope that after installing newest version 2.1.1.1 which is on site now you won't have any problems as well.

Nicolas
Posts: 21
Joined: Thu Sep 04, 2003 3:31 pm

Post by Nicolas »

I do confirm that unexpected end of file show up whith 2.1.1.1 version. So I downgraded to 2.1.0.3 version.

Post Reply