SiComponents Home Page SiComponents Forums
Here you will be able to get help and share your experience
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Empty Password Bug

 
Post new topic   Reply to topic    SiComponents Forums Forum Index -> VCL Scheduling Agent
View previous topic :: View next topic  
Author Message
mimarsinan



Joined: 20 Apr 2006
Posts: 2

PostPosted: Thu Apr 20, 2006 10:07 pm    Post subject: Empty Password Bug Reply with quote

Scheduling a task with an empty password does not work. I can schedule the same task in the native task scheduler with an empty password and it works. However the scheduler does not successfully schedule a task with an empty pasword. (The user account has an empty password)
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2097

PostPosted: Fri Apr 21, 2006 3:46 am    Post subject: Reply with quote

Actually, this is some XP limitation, as described here:
http://www.theeldergeek.com/scheduled_tasks_password.htm

But the code below works just fine to configure a task for a user without password:
Code:
     
      Flags := Flags + [tfRunOnlyIfLoggedOn];
      SetAccountInformation('USERNAME', '');


You may need to use a trick as:
Go to Start/Administrative Tools/'Local Security Policy/Security Settings\Local Policies\Security Options
Accounts: Limit local account use of blank passwords to console logon only. This is enabled by default, disable it.

Please let me know if this helps.
Back to top
View user's profile Send private message
jbjorgen



Joined: 12 Oct 2006
Posts: 1

PostPosted: Thu Oct 12, 2006 3:37 pm    Post subject: Reply with quote

mimarsinan has a point.

I can manually configure a task with no password in Windows XP. Also, an application compiled with version 1.0.2 of the scheduling agent seems to have no problem with adding a blank password task to Windows XP without error. Both work without the "Run only if logged in" option.

Unfortunately, I lost the installer for 1.0.2 due to a hard disk failure, I need to get that functionality back. Any ideas?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SiComponents Forums Forum Index -> VCL Scheduling Agent All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by p h p B B  © 2001, 2005 p h p B B  Group