SiComponents Home Page SiComponents Forums
Here you will be able to get help and share your experience
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

problems with some controls...

 
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite
View previous topic :: View next topic  
Author Message
Rafal



Joined: 10 Oct 2005
Posts: 3

PostPosted: Wed Oct 26, 2005 10:59 am    Post subject: problems with some controls... Reply with quote

Hi,
I have almost decided to use your siLang component when I came across some problemsÖ I have tested it with a few our controls and it worked fine but then translating ordinary buttons (TButton), instead of Polish diacritics (Iím translating English into Polish) I get some garbage marks. It is strange because with TBitBtn it works fine. Iíve got the same problem with the menu and form captionsÖ Iím using English version of Windows XP and Delphi 6 with all the updates. I donít know what I am doing wrong. Could you help please? It is very urgent to me. Please contact me on my e-mail if you need any further information (screenshots etc.). Many thanks in advance.
There is one more minor problem: the combination of right alt +s and right alt+a are used to enter two of Polish diacritics. When using your translation editor, those keys bring some dialogs up. Is it possible to turn those key shortcuts off?
Best regards
Rafal
rafal@bykowce.pl
Back to top
View user's profile Send private message
Haron



Joined: 11 Mar 2004
Posts: 39

PostPosted: Wed Oct 26, 2005 8:01 pm    Post subject: Re: problems with some controls... Reply with quote

> I’ve got the same problem with the menu and form captions…

Check you have propery charset and font set for these objects. Maybe you set "ParentFont = False" ?

> the combination of right alt +s and right alt+a are used

This is UI bug of Translation Editor. Igor will fix it later. Of course only Ctrl + <char> should be used.
Back to top
View user's profile Send private message
Rafal



Joined: 10 Oct 2005
Posts: 3

PostPosted: Thu Oct 27, 2005 11:10 am    Post subject: Reply with quote

Hello,
I did try setting ParentFont to false but it didn't work... This is strange because the properties of the controls seem to be the same, yet some of them work fine and some do not...
The other thing is that every time I open Translation Editor by double clicking on the TsiLang icon, the new, duplicated lines appear for the same controls in the CharSets table.

Please have a look at the screenshot:


I'd be grateful for any help

Best regards
Rafal
Back to top
View user's profile Send private message
Haron



Joined: 11 Mar 2004
Posts: 39

PostPosted: Thu Oct 27, 2005 7:48 pm    Post subject: Reply with quote

> I did try setting ParentFont to false but it didn't work

You should set it to True to inherite form settings.

> duplicated lines appear for the same controls in the CharSets table. Please have a look at the screenshot

Very interesting, but I don't see any file at URL given.
Back to top
View user's profile Send private message
Rafal



Joined: 10 Oct 2005
Posts: 3

PostPosted: Fri Oct 28, 2005 9:09 am    Post subject: Reply with quote

Hi Haron,
thanks for your reply.
I was trying to set ParentFont to True and False but it didn't change a thing...
Could you just copy and paste http://rafal.co.uk/untitled.PNG into your browser and check whether you can see the picture, please?
Cheers
Rafal
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2102

PostPosted: Fri Oct 28, 2005 2:12 pm    Post subject: Reply with quote

Hello,

Sorry for delay with reply.
The problem with TButton and some other controls is that they are just wrappers of Windows controls and draw themselves using Default System locale. This is described here http://www.sicomponents.com/forum/viewtopic.php?t=12 So the only way to perform this is to set either:
1. Default Locale to Polish
2. Replace controls with "OwnerDraw" components like TButton with TBitBtn and so on.
3. Replace controls with Unicode analogues, like TNTControls from http://www.tntware.com


We'll try to fix the problem with shortcuts.

Hope this helps.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by p h p B B  © 2001, 2005 p h p B B  Group