SiComponents Home Page SiComponents Forums
Here you will be able to get help and share your experience
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Support for XE8

 
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite
View previous topic :: View next topic  
Author Message
PStadler



Joined: 02 Mar 2007
Posts: 19

PostPosted: Fri Apr 17, 2015 5:40 am    Post subject: Support for XE8 Reply with quote

Hello,

When do you expect support vor XE8?

Sincerely

Peter
Back to top
View user's profile Send private message Send e-mail
Malcolm



Joined: 21 Jan 2003
Posts: 84
Location: Scotland

PostPosted: Sat Apr 18, 2015 9:14 am    Post subject: Reply with quote

I don't usually push for early releases .. but ..

I have an Android app which crashes under XE7 and earlier due to a library bug which has been fixed in XE8. The only 3rd party component I need before I can release a fixed version of my app is .. TsiLang.

If your XE8 support is not imminent, do you know if I can compile and install your XE7 version in XE8?

Malcolm
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2097

PostPosted: Sat Apr 18, 2015 7:47 pm    Post subject: Reply with quote

We're preparing new version with XE 8 support. Meantime XE 7 package could be easily installed and used under XE 8.
Back to top
View user's profile Send private message
Malcolm



Joined: 21 Jan 2003
Posts: 84
Location: Scotland

PostPosted: Sun Apr 19, 2015 2:00 pm    Post subject: Reply with quote

Thanks Igor

The XE7 setup.exe ran OK, but the components were not installed.
I don't know enough about how to change the settings to get the package installed so I will just try to be patient. Embarassed
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2097

PostPosted: Mon Apr 20, 2015 8:46 am    Post subject: Reply with quote

I meant that if you have Full Source license you can manually install XE 7 packages into XE 8 IDE. Sorry for confusion. Just open TsiLang XE7 project group, build both packages and install the TsiLang_XE7.dpk into IDE.
Back to top
View user's profile Send private message
fherrero



Joined: 05 Nov 2008
Posts: 1

PostPosted: Mon May 04, 2015 7:12 am    Post subject: Error XE8 Reply with quote

Hi!, I'm trying to install the latest version of your component in RAD Studio XE8. The project compiles but when I try to install the bpl compiled in the XE8 environment fails. I must change anything of your code to get a correct bpl for the new environment. Please, can you give to us a more detailed explanation to get a usable version of your component in the XE8 environment? Thanks in advance.

I must change anything of your code to get a correct bpl for the new environment... Is needed any change in your code to get a correct bpl for the new environment?
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2097

PostPosted: Mon May 04, 2015 10:08 am    Post subject: Reply with quote

Version 7.4 just released with support for XE 8!
Back to top
View user's profile Send private message
Malcolm



Joined: 21 Jan 2003
Posts: 84
Location: Scotland

PostPosted: Mon May 04, 2015 10:36 pm    Post subject: Reply with quote

Brilliant, Thanks.
(I failed to compile and install my XE7 source into XE8)
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by p h p B B  © 2001, 2005 p h p B B  Group