SiComponents Home Page SiComponents Forums
Here you will be able to get help and share your experience
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

MessageDlg

 
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite
View previous topic :: View next topic  
Author Message
ix07



Joined: 26 May 2009
Posts: 15

PostPosted: Mon Aug 31, 2009 4:45 pm    Post subject: MessageDlg Reply with quote

Hi.

I'm trying to use SiLang to translate the standard message dialogs. I have placed a TsiLang-component on a data-module and translated all required strings in the "Dialogs"-section. This component is connected to a language-dispatcher component. However when I call "siLang1->MessageDlg(msg, dlgType, buttons, helpCtx, defaultBtn, cancelBtn);" I always get the untranslated standard text, regardless of which "ActiveLanguage" is set (that from the first column). When inspecting the TsiLang-component "ActiveLanguage" has the correct value. Changing it manually in the debug-inspector also results in the same result-string.

What's wrong? Any ideas?

Thanks

Best Regards

P.S.:
Using TsiLang version 6.4 with CB2007
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2103

PostPosted: Tue Sep 01, 2009 9:04 am    Post subject: Reply with quote

Hi,

We can't find a problem in such way, but I can suppose that the prblem somewhere in your code. You can try to create a sample ptoject with the MessageDlg() functionality and check if it works with TsiLang. Later investigate your code to try to find the origin of problem or the difference.

Hope this helps.
Back to top
View user's profile Send private message
Jean-Paul Brassard



Joined: 08 May 2008
Posts: 65

PostPosted: Tue Sep 01, 2009 4:01 pm    Post subject: Re: MessageDlg Reply with quote

ix07 wrote:
I'm trying to use SiLang to translate the standard message dialogs. I have placed a TsiLang-component on a data-module and translated all required strings in the "Dialogs"-section. This component is connected to a language-dispatcher component. However when I call "siLang1->MessageDlg(msg, dlgType, buttons, helpCtx, defaultBtn, cancelBtn);" I always get the untranslated standard text, regardless of which "ActiveLanguage" is set (that from the first column). When inspecting the TsiLang-component "ActiveLanguage" has the correct value. Changing it manually in the debug-inspector also results in the same result-string.

Hi,
The problem can come from many sources.
1-Check that the link properties between TsiLang components are correctly specified (at run time).

2-You can try to manually remove the TsiLang component from your DFM (after saving its contents in a SIB or SIL), then put a fresh Tsilang component back and reload its contents.

3-If you bought the Full Source version of TsiLang, you can trace the window creation to see what happens with the Dialog messages. TsiLang has special code to create those messages if it does not find them at window creation. I seen a TsiLang bug around this feature in a previous version of TsiLang... You may be fall onto another bug.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by p h p B B  © 2001, 2005 p h p B B  Group