SiComponents Home Page SiComponents Forums
Here you will be able to get help and share your experience
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

What to do with a translated .sil file?

 
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite
View previous topic :: View next topic  
Author Message
pls



Joined: 09 Feb 2004
Posts: 13
Location: Phoenix, AZ, USA

PostPosted: Fri Feb 13, 2004 5:12 am    Post subject: What to do with a translated .sil file? Reply with quote

I saved all strings from my CBuilder6 project to a .sil file and had it translated. Now I'm wondering what to do with the sil file.

I opened CBuilder, went into the TsiLang expert, and tried both "Load project" and "Merge Project" and selecting the translated .sil file. Neither of these put the translations into the language expert.

I tried cutting the translations from the original Word document and pasting them into the Expert, but the don't appear in Greek. Yes, I have selected a font that has Greek and the charset is set to Greek.

What might be wrong?

Thanks,
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2103

PostPosted: Fri Feb 13, 2004 6:09 am    Post subject: Reply with quote

Do you able to open SIL file in SIL Editor and see all its content correctly? It looks like something wrong with SIL file.
Please check that its format is correct. There should be the sections as in INI files: [Captions], [Hints] and so on. Each section should list components for each form: TForm1.Label1, TForm1.Label2 and so on.
Back to top
View user's profile Send private message
pls



Joined: 09 Feb 2004
Posts: 13
Location: Phoenix, AZ, USA

PostPosted: Fri Feb 13, 2004 9:07 am    Post subject: Reply with quote

Yes, I can open the file in the editor and it looks fine.

I did notice one thing. If I enter translations in the Expert in the BCB IDE, they go away after I load the .sil file, but the translations from the sil fle are not put in place.

I've looked at the .sil file and it seems fine. The entries that were translated have the format
TConfig.Label1=[English text][delimiter string][Greek text]
I'm not used to looking at this file so I may be missing something.

Would you mind looking at it? Contact me at the address in my profile and I'll send you whatever pieces of the project you need.

Thanks,
++PLS
Back to top
View user's profile Send private message
pls



Joined: 09 Feb 2004
Posts: 13
Location: Phoenix, AZ, USA

PostPosted: Fri Feb 13, 2004 9:17 am    Post subject: Reply with quote

By the way, any idea why cut from Word and paste into the tsiLand Expert doesn't work? The pasted string is mostly question marks.

++PLS
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by p h p B B  © 2001, 2005 p h p B B  Group