SiComponents Home Page SiComponents Forums
Here you will be able to get help and share your experience
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

unigui support

 
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite
View previous topic :: View next topic  
Author Message
nurettin



Joined: 16 May 2016
Posts: 5

PostPosted: Mon May 16, 2016 12:52 pm    Post subject: unigui support Reply with quote

Hi, our company is planning to purchase sicomponents.

At work we use unigui ( http://unigui.com ) and we compile our program as an ISAPI DLL. When we place TsiLang component on a form, compile the application and try to open the page from a browser, it doesn't load.

I tried enabling exceptions on the tsilang component,
I checked the logs, there are no errors.
I snooped around with a process explorer, didn't see any errors.

What might tsilang component be doing that makes it fail to load when run from ISAPI DLL?

We would like to have a fix or workaround if possible.

Thanks for your time.
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2097

PostPosted: Tue May 17, 2016 3:28 am    Post subject: Reply with quote

Hello,

Unfortunately, we were unable to test the uniGUI in order to try to find the reason for the problem. We've downloaded their trial version available on their forum but all demo projects can't be opened in IDE due to errors. As well as there is no new uniGUI project wizard available in IDE so we don't know how to create new uniGUI project. Sad
Back to top
View user's profile Send private message
nurettin



Joined: 16 May 2016
Posts: 5

PostPosted: Tue May 17, 2016 8:05 am    Post subject: Reply with quote

isiticov wrote:
Hello,

Unfortunately, we were unable to test the uniGUI in order to try to find the reason for the problem. We've downloaded their trial version available on their forum but all demo projects can't be opened in IDE due to errors. As well as there is no new uniGUI project wizard available in IDE so we don't know how to create new uniGUI project. Sad


Hi,

We can install unigui and build demo projects on Delphi XE7. I hope that helps.
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2097

PostPosted: Wed May 18, 2016 3:12 am    Post subject: Reply with quote

Do you use FULL version of uniGUI? Because the trial version available on their web site doesn't work under XE7
Back to top
View user's profile Send private message
nurettin



Joined: 16 May 2016
Posts: 5

PostPosted: Fri May 20, 2016 8:50 am    Post subject: Reply with quote

isiticov wrote:
Do you use FULL version of uniGUI? Because the trial version available on their web site doesn't work under XE7


Yes, we use the full version, but we did try it before we bought it and the demos built.

Can you tell me the errors? Perhaps I can redirect them to the forums.
Back to top
View user's profile Send private message
nurettin



Joined: 16 May 2016
Posts: 5

PostPosted: Fri May 20, 2016 10:09 am    Post subject: Reply with quote

isiticov wrote:
Do you use FULL version of uniGUI? Because the trial version available on their web site doesn't work under XE7


Actually I just tried a bare-bones ISAPI DLL (WebBroker/Web Application/ISAPI) with a tsilang component on the webmodule unit and the same thing happened.

So I guess it wasn't really about unigui.

Can you please help me resolve the issue of running TsiLang components on any ISAPI DLL?
Back to top
View user's profile Send private message
farshad



Joined: 20 May 2016
Posts: 2

PostPosted: Sat May 21, 2016 3:44 am    Post subject: Reply with quote

isiticov wrote:
Hello,

Unfortunately, we were unable to test the uniGUI in order to try to find the reason for the problem. We've downloaded their trial version available on their forum but all demo projects can't be opened in IDE due to errors. As well as there is no new uniGUI project wizard available in IDE so we don't know how to create new uniGUI project. Sad


Hi,

You need to follow uniGUI installation instructions. You must build and install uniGUI design time packages in IDE. Instructions are in uniGUI.pdf which is available after installing.
Back to top
View user's profile Send private message
farshad



Joined: 20 May 2016
Posts: 2

PostPosted: Sat May 21, 2016 12:58 pm    Post subject: Re: unigui support Reply with quote

nurettin wrote:
Hi, our company is planning to purchase sicomponents.

At work we use unigui ( http://unigui.com ) and we compile our program as an ISAPI DLL. When we place TsiLang component on a form, compile the application and try to open the page from a browser, it doesn't load.

I tried enabling exceptions on the tsilang component,
I checked the logs, there are no errors.
I snooped around with a process explorer, didn't see any errors.

What might tsilang component be doing that makes it fail to load when run from ISAPI DLL?

We would like to have a fix or workaround if possible.

Thanks for your time.


Are you using the trial edition of TsiLang? Maybe it is a restriction of trial edition.
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2097

PostPosted: Sun May 22, 2016 6:05 am    Post subject: Reply with quote

Hello,

We've found a reason for that! Thank Farshad for the hint. Trial version displays a trial message when application is running without IDE! And so when running under web server it can't detect IDE running and will display this message. But under web server this message can't be displayed as result the application hangs.
Back to top
View user's profile Send private message
nurettin



Joined: 16 May 2016
Posts: 5

PostPosted: Mon May 23, 2016 5:44 am    Post subject: Reply with quote

isiticov wrote:
Hello,

We've found a reason for that! Thank Farshad for the hint. Trial version displays a trial message when application is running without IDE! And so when running under web server it can't detect IDE running and will display this message. But under web server this message can't be displayed as result the application hangs.


That is great news, so release version won't have that problem. Will this behavior be changed in the future?
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2097

PostPosted: Tue May 24, 2016 4:02 am    Post subject: Reply with quote

Hello,

The registered version doesn't have such issue. Trial version has this limitation.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by p h p B B  © 2001, 2005 p h p B B  Group