SiComponents Home Page SiComponents Forums
Here you will be able to get help and share your experience
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Problems with Internet Translate

 
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite
View previous topic :: View next topic  
Author Message
PvdL



Joined: 02 Jan 2014
Posts: 11

PostPosted: Tue Apr 15, 2014 5:21 pm    Post subject: Problems with Internet Translate Reply with quote

Using the latest versions I have some problems with Internet Translate. For example: %s is not a valid value for field '%s'. The allowed range is %s to %s

Translated to German: Der zulässige Bereich ist% s% s As you can see it misses the first part of the sentence and the %s is not correct formatted (ie. it has a space between % and s). When I remove the period of the first sentence and do a translate it results to: % S ist kein gültiger Wert für Feld '% s' Der zulässige Bereich ist% s% s

Again, it's not good. Extra spaces and capital S.
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2103

PostPosted: Thu Apr 17, 2014 1:28 am    Post subject: Reply with quote

Unfortunately, this is how Google Translate works when it meets %s in original strings. We will try to find a way how to imporve this from our side.
Back to top
View user's profile Send private message
PvdL



Joined: 02 Jan 2014
Posts: 11

PostPosted: Thu Apr 17, 2014 6:48 am    Post subject: Reply with quote

Okay, thank you.
Back to top
View user's profile Send private message
PvdL



Joined: 02 Jan 2014
Posts: 11

PostPosted: Sun Jun 29, 2014 12:51 pm    Post subject: Still not solved in 7.2 Reply with quote

Google translate is still not working properly, ie. it's still the same...
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2103

PostPosted: Tue Jul 01, 2014 5:58 pm    Post subject: Reply with quote

Just fixed this. Please check. There is now an additional button that will try to fix incorrect Google Translate behavior with % strings.
Back to top
View user's profile Send private message
PvdL



Joined: 02 Jan 2014
Posts: 11

PostPosted: Sat Jul 05, 2014 3:06 pm    Post subject: Reply with quote

Yes, button works 9 out of ten times. Still some translation errors that doesn't fix by this button. ie. % 5.4f
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by p h p B B  © 2001, 2005 p h p B B  Group