SiComponents Home Page SiComponents Forums
Here you will be able to get help and share your experience
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

TsiLang changing font property

 
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite
View previous topic :: View next topic  
Author Message
ix07



Joined: 26 May 2009
Posts: 15

PostPosted: Wed Feb 19, 2014 2:49 pm    Post subject: TsiLang changing font property Reply with quote

Hi.

I want my application to use a consistent font for all forms, however TSiLang makes that difficult for me. Whenever I import translation data it touches or changes the font property of controls in the forms/frames and that also changes the "ParentFont" property to "false". Is there any way to keep TSiLang from touching the font of controls/forms/frames?

Thanks

Best Regards
Eike Petersen
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2096

PostPosted: Wed Feb 19, 2014 4:59 pm    Post subject: Reply with quote

1. Open Translation Editor.
2. Go to menu Tools | Setttings
3. Click to deactivate "Auto-set default Fonts and Charsets"
After this Translation Editor won't automatically insert values for Fonts and Charsets for languages defined in Default Fonts.
Back to top
View user's profile Send private message
ix07



Joined: 26 May 2009
Posts: 15

PostPosted: Wed Feb 26, 2014 2:38 pm    Post subject: Reply with quote

Are you sure that will help? Please note that I import translations via the "TSiLang Expert" from the "Tools"-menu. Within the expert I use the menu "File/Load translation" and then "Load project" or "Load language for project". I can`t find such an option in the expert, and I don`t see any property at the TSiLang-components which would store such setting, so I assume this is a "Translation editor" setting which only is valid for the editing session?

Thanks.
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2096

PostPosted: Wed Feb 26, 2014 4:46 pm    Post subject: Reply with quote

If you load translations from external file than fonts will be changed only if your external file contains Fonts data, so when loading TsiLang changes this property. When control's Font property differs from its parent font the ParentFont property automatically changes to False. So just clear Fonts and Charsets in your external file using SIL Editor and this should resolve the problem. Or setup Fonts and Charset settings there the same as you have in your sources.
Back to top
View user's profile Send private message
ix07



Joined: 26 May 2009
Posts: 15

PostPosted: Thu Jul 30, 2015 2:40 pm    Post subject: Reply with quote

Hi.

Unfortunately this is still not resolved for me. Tsilang frequently touches the font property which is very annoying, especially when designing a GUI which is high dpi capable. Couldn't you implement a property "dont change fonts" or "Use Parent Font" on the tsilang component? It frequently happens that i open a tsilang component in the designer and after changing a text all fonts are changed in the form/frame. After that on all components the "ParentFont" property is set to "False" and I have to check all my controls. Very annoying!

Thanks.
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2096

PostPosted: Fri Jul 31, 2015 9:11 am    Post subject: Reply with quote

Hello,
It just looks like you still have "Auto use Default Fonts" option activated.

1. Open Translation Editor (double-click on TsiLang).
2. Go to menu Tools | Setttings
3. Click to deactivate "Auto-set default Fonts and Charsets"
After this Translation Editor won't automatically insert values for Fonts and Charsets for languages defined in Default Fonts.

Additionally, you can just exclude the Fonts from translations at all:
1. Select TsiLang.
2. Double-click ExcludedProps property in object inspector.
3. Select form in the tree and then double-click on Font property in Available Properties list.
This will empty Fonts and Charsets lists in TsiLang and TsiLang will never touch Font property for any component on this form.
Back to top
View user's profile Send private message
ix07



Joined: 26 May 2009
Posts: 15

PostPosted: Sun Aug 02, 2015 4:01 pm    Post subject: Reply with quote

Using ExcludedProps sounds like a good idea. I will try that. Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by p h p B B  © 2001, 2005 p h p B B  Group