SiComponents Home Page SiComponents Forums
Here you will be able to get help and share your experience
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Armenian language

 
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite
View previous topic :: View next topic  
Author Message
Hrant



Joined: 13 Sep 2011
Posts: 2

PostPosted: Thu Sep 15, 2011 1:23 pm    Post subject: Armenian language Reply with quote

Hi
When I try to start the Armenian language translation in SIL Editor, the Armenian words corrupted, when I am closing the program all they become the question mark: ?????.
Can someone say me what's a problem?
Thanks.
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2097

PostPosted: Fri Sep 16, 2011 12:42 am    Post subject: Reply with quote

Hello,

Armenian language doesn't have a Charset associated and this results to chars corruptions when using in ANSI SIL/SIB files when editing Armenian under non-Armenian default locale. There is 2 ways to workaround this:
1. Use UTF-8 SIL/SIB files. Menu File | Convert...
2. Set OS's default locale to Armenian (Language for non-Unicode programms setting from Regional Settings).

Hope this helps.
Back to top
View user's profile Send private message
Hrant



Joined: 13 Sep 2011
Posts: 2

PostPosted: Sun Sep 18, 2011 7:05 am    Post subject: Reply with quote

isiticov wrote:
Hello,

Armenian language doesn't have a Charset associated and this results to chars corruptions when using in ANSI SIL/SIB files when editing Armenian under non-Armenian default locale. There is 2 ways to workaround this:
1. Use UTF-8 SIL/SIB files. Menu File | Convert...
2. Set OS's default locale to Armenian (Language for non-Unicode programms setting from Regional Settings).

Hope this helps.


Hi
Thanks for answer!
I have a another question:
I have translated some file in .xml file.
How I can import it in SilEditor in UTF-8 format (when I import it, the SilEditor's default Charset becoming ANSI.
Thanks.
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2097

PostPosted: Mon Sep 19, 2011 11:02 am    Post subject: Reply with quote

When you export UTF-8 SIL or SIB file to XML there is included a node in XML like <Source_UTF-8>True</Source_UTF-8> under HEAD section. So when you import this file back to SIL Editor the imported file will be UTF-8 if this line exists.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by p h p B B  © 2001, 2005 p h p B B  Group