SiComponents Home Page SiComponents Forums
Here you will be able to get help and share your experience
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

TsiLangExpert load SIL file - corrupt Russian language

 
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite
View previous topic :: View next topic  
Author Message
Phoner



Joined: 02 May 2006
Posts: 23

PostPosted: Tue May 05, 2009 8:25 am    Post subject: TsiLangExpert load SIL file - corrupt Russian language Reply with quote

I am using TsiLang version 6.4 and Delphi2009.
My application supports Russian language (Cyrillic) - the charset is set correctly. I can save the project to SIL file. This SIL file can be changed without problems - all Russian letters are displayed correctly.
Loading this changed SIL file again with TsiLangExpert destroys the Russian language - only cryptic signs are visible.
What is wrong here?
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2097

PostPosted: Wed May 06, 2009 7:49 am    Post subject: Reply with quote

Do you use StoreAsUTF8 property of TsiLang?
Back to top
View user's profile Send private message
Phoner



Joined: 02 May 2006
Posts: 23

PostPosted: Thu May 07, 2009 11:30 am    Post subject: Reply with quote

No. In some earlier post you told me not to do so.
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2097

PostPosted: Mon May 11, 2009 4:27 am    Post subject: Reply with quote

Could you please send us sample project that reproduces this problem? Since we tried to reproduce this and it worked just fine.
Back to top
View user's profile Send private message
Phoner



Joined: 02 May 2006
Posts: 23

PostPosted: Thu May 14, 2009 9:10 am    Post subject: Reply with quote

I sent you a mail, because I don't know how to attach something here in the forum.
I hope you received the mail and can reproduce the problem.
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2097

PostPosted: Thu May 14, 2009 4:37 pm    Post subject: Reply with quote

Yes, thank you for the sample. We're investigating it...
Back to top
View user's profile Send private message
Phoner



Joined: 02 May 2006
Posts: 23

PostPosted: Wed Jul 29, 2009 1:36 pm    Post subject: Reply with quote

I've just installed version 6.4.1 - but the problem keeps the same.
Save the project from TsiLangExpert and load back destroys my Russian language. All other languages seems to be OK. Russian is the only language not using Latin characters in my project.
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2097

PostPosted: Thu Jul 30, 2009 8:13 am    Post subject: Reply with quote

Do you have proper settings for CharSets for Russian language?
Back to top
View user's profile Send private message
Phoner



Joined: 02 May 2006
Posts: 23

PostPosted: Mon Aug 03, 2009 2:00 pm    Post subject: Reply with quote

Yes, RUSSIAN_CHARSET is set for all entries in the column for Russian language.
The created SIL file can be loaded with SILEdior without problems. All Russian strings are displayed OK. Only loading a SIL file with the expert produces the wrongs characters.
Back to top
View user's profile Send private message
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2097

PostPosted: Tue Aug 04, 2009 12:41 pm    Post subject: Reply with quote

Do you modify SIL file in SIL Editor before loading? Or just simple- save-load produces corruption of the characters?
Back to top
View user's profile Send private message
Phoner



Joined: 02 May 2006
Posts: 23

PostPosted: Wed Aug 05, 2009 3:07 pm    Post subject: Reply with quote

I have the problem without using the SILEditor at all. Just save and load with the expert produces the wrong characters.
I just tested with SILEditor the saved file. That file seems to be OK.
Back to top
View user's profile Send private message
Phoner



Joined: 02 May 2006
Posts: 23

PostPosted: Sun Sep 13, 2009 9:54 am    Post subject: Reply with quote

Now I tried version6.5 - the problem still exists. I have to put in changled translations manually. I can't load the project from SIL file without destroying Russian language.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by p h p B B  © 2001, 2005 p h p B B  Group