SiComponents Home Page SiComponents Forums
Here you will be able to get help and share your experience
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

TChart problems

 
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite
View previous topic :: View next topic  
Author Message
pablobr



Joined: 21 Sep 2004
Posts: 18

PostPosted: Wed Jun 22, 2005 5:34 pm    Post subject: TChart problems Reply with quote

Hi all,

Well, in my application I have severals charts. I used the ExtendedTranslations property to translate the properties I needed.
Now comes the problem... at my DataModuleīs ONCreate event I read a .INI file and set the right language. But dont know why, the extended translations (Charts title, axis title, etc...) dont work.
At the application I have an option to change the language. If I set the language to the same language, the extended translations now works.

Ps: I use the event siLangDispatcher1.LoadAllFromFile on both methods, on the oncreate event and on the option inside the application.

Hope anyone could help me...

Best regards

Pablo
Back to top
View user's profile Send private message MSN Messenger
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2103

PostPosted: Wed Jun 22, 2005 6:12 pm    Post subject: Reply with quote

May be the form with chart is created after the loading of file is performed and the loaded file doesn't have translations for chart (please check this http://www.tsilang.com/delphiglobalizationtool_faq.html#19 in order to be sure your loading is correct).
In case this doesn't help please try to reproduce this behavior on sample project and send it to us. We will try to investigate and to find the reason for this.
Back to top
View user's profile Send private message
pablobr



Joined: 21 Sep 2004
Posts: 18

PostPosted: Wed Jun 22, 2005 6:47 pm    Post subject: finally Reply with quote

I heard about the loadallfromfile here on the forum, and I was using it wrong.
Now it workīs. Very Happy

Really Thanks
Back to top
View user's profile Send private message MSN Messenger
pablobr



Joined: 21 Sep 2004
Posts: 18

PostPosted: Wed Aug 10, 2005 4:47 pm    Post subject: What the... Reply with quote

Hi all,

Mine extended translations was supposed to work until now!
But it doesnīt work anymore. I checked and the form with the charts is created later then the loadallfromfile function.
I lost about more than 10 hours trying to fix it and nothing until now!

Anyone have a suggestion?

Please,

Pablo
Back to top
View user's profile Send private message MSN Messenger
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2103

PostPosted: Wed Aug 10, 2005 5:59 pm    Post subject: Reply with quote

May be SIL/SIB file was recreated or corrupted somehow?
Back to top
View user's profile Send private message
pablobr



Joined: 21 Sep 2004
Posts: 18

PostPosted: Wed Aug 10, 2005 7:44 pm    Post subject: ... Reply with quote

Well itīs working now, but I donīt know why...

The last time it worked, all I had done was to translate the .SIBīs extended strings and use LoadAllFromFile function.

But this time I had to translate the .SIBīs extended strings and then get back to Delphi and click on File --> Save/Load Translations --> Load Form(s) and load the strings translated from my .SIB file.

Any ideia on what could be the problem?

Regards,

Pablo
Back to top
View user's profile Send private message MSN Messenger
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2103

PostPosted: Thu Aug 11, 2005 5:09 am    Post subject: Reply with quote

No idea except: SIB didn't contain translations for those strings.
But I doubt this is applicable Smile
Back to top
View user's profile Send private message
pablobr



Joined: 21 Sep 2004
Posts: 18

PostPosted: Thu Aug 11, 2005 2:08 pm    Post subject: ... Reply with quote

I concluded that the LoadAllFromFile is not working for my extended translations, because I removed the LoadAllFromFileīs call and the extended translations keep working fine.

Well, its better working like this than when it was not supposed to work. I think this is very uncomon.

Regard,

Pablo
Back to top
View user's profile Send private message MSN Messenger
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2103

PostPosted: Thu Aug 11, 2005 6:17 pm    Post subject: Reply with quote

This is strange but we just checked and LoadAllFromFile loads extended as well.
Are you able to reproduce the problem on simple project and send it to us?
Back to top
View user's profile Send private message
pablobr



Joined: 21 Sep 2004
Posts: 18

PostPosted: Fri Aug 12, 2005 11:23 am    Post subject: Reply with quote

isiticov wrote:
This is strange but we just checked and LoadAllFromFile loads extended as well.
Are you able to reproduce the problem on simple project and send it to us?


Well, I tried to reproduce it, but without success.
So, I did a few tests on my application and concluded that only on a specific Form this happens.
I created a new form with a TChart on it and the extended translations works fine.
I checked and the form with problems isnīt created after the LoadAllFromFile function. I really donīt know what to do.
Any ideia?

Regards,

Pablo
Back to top
View user's profile Send private message MSN Messenger
isiticov
Site Admin


Joined: 21 Nov 2002
Posts: 2103

PostPosted: Fri Aug 12, 2005 12:17 pm    Post subject: Reply with quote

Absolutely no idea Sad
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by p h p B B  © 2001, 2005 p h p B B  Group