SiComponents Home Page SiComponents Forums
Here you will be able to get help and share your experience
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Chinese

 
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite
View previous topic :: View next topic  
Author Message
Kev



Joined: 01 Apr 2005
Posts: 24

PostPosted: Tue Apr 19, 2005 2:46 pm    Post subject: Chinese Reply with quote

I am still having no luck getting Chinese chars into the Editor. I can copy from Babblefish and paste into Excel, Word, etc with no problem. I can use WinXP Chinese IME or NJStar to enter into these with no problem. I am trying to use the editor (downloaded) completely outside of Borland. Most times, after pasting, I get some chinese chars and some ???'s in the box. I have tried Arial Unicode, MS SansSerif and fonts and all combinations of Char sets. Iactually have gotten a few correct chars into the editor at times, but I cannot reproduce how I did it. I just purchased this component and I am a little disappointed. I followed the instructions Igor sent me and still cannot get it to work properly.

How can I possible send the editor t a translator and have them be able to enter the proper chars without having to do all kinds of convoluted steps with their operating system and expect it to work?

I really do think this is a nice way to globalize my program especially since I can let the customer edit the strings, but what is the point if the strings cannot be pasted in effeciently?

Any further help would be greatly appreciated. Can someone post a very detailed instruction on how to enter Chinese. Start with a WinXP Pro operating system and only use the outside editor. Do not even involve Borland or the components. Has anyone used NJStar for IME?

Thanks,
Kev
Back to top
View user's profile Send private message
Kev



Joined: 01 Apr 2005
Posts: 24

PostPosted: Tue Apr 19, 2005 4:57 pm    Post subject: Possibly Fixed Reply with quote

OK, looks like I missed a step. I was setting the Default Fontand Char set from the main menu, but missed setting them from the pick list on the left side panel. That looks like it fixed most, but not all the chinese strings.

Couls someone check something out for me? Go to http://babelfish.altavista.com/ and select translate From English to Chinese simplified. Enter theword Chart in editor thentranslate. Copy the translation to the clipboard and paste into the SiEditor. All looks fine on mine until it gets to the Borland IDE. This is a button caption and other words/phrases show up fine when I have NJStar turned on.This word and some others do the same.

Thanks,
Kev
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    SiComponents Forums Forum Index -> TsiLang Components Suite All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by p h p B B  © 2001, 2005 p h p B B  Group